作者归档:丑丑

源码编译安装Nginx

之前写过一篇《debian 9 系统中安装新版的nginx(支持tsl1.3)》关于开启tsl1.3的先决条件:(1)nginx版本必须在1.13或者更新
(2)、Nginx需要使用OpenSSL 1.1.1以上的版本构建或与OpenSSL 1.1.1以上的版本一起运行。这段话没有错,因为自己也是刚接触这块也是小白一个,结果认为只要是系统Openssl版本在1.1.1以上,nginx版本在1.13以上就支持。结果实际情况是:我的系统用的Debian9 系统自带的opessl版本是1.1.1g也满足条件,nginx我是通过apt install安装的,版本是1.18.0我想着应该支持了。然后每次在浏览器中访问站点,查看的时候还是tsl1.2。过了好长一段时间我在用nginx -V 查看的时候才发现这个版本的nginx是基于OpenSSL1.1.0构建的,上网一查才发现Debian9 apt仓库里的nginx的OpenSSL版本比较低,原来问题在这。好吧那就自己重新编译安装一下。

一、编译安装前的准备工作

继续阅读

WordPress SMTP邮件发送插件WP Mail SMTP之Gmail设置

        WordPress很多功能需要发送邮件,比如常见的找回密码操作、新用户注册等需要发送邮件,但是默认情况下WordPress是无法发送邮件。下面主要介绍一下gmail配置方法。

一、WP Mail SMTP插件的安装

这里就不过多介绍,直接登录wordpress站点后台:插件——安装插件——搜索”wp mail smtp”点击安装就行了如图:
继续阅读